Back to overview
Resolved

🛠️ Scheduled Maintenance Notice

Aug 17, 2026 at 9:00am UTC  –  Aug 17, 2026 at 11:18am UTC
Affected services
[Maincubes] Ryzen 9 9950X3D

Resolved
Aug 17, 2026 at 11:18am UTC

All clients who would like to receive +1 additional day added to their service are kindly asked to open a ticket on Billing and specify that they are requesting the maintenance compensation.

Our team will review the request and add the extra day to the respective service.

Thank you once again for your patience and understanding. ❤️

Kind regards,
neohost.ro

Created
Aug 17, 2026 at 9:00am UTC

We will be performing scheduled maintenance on 17 August 2026 from 12:00 to 13:30 EEST.

This maintenance only affects Servers located in our Germany region, specifically those running on our Ryzen 9 9950X3D node. All other services and regions will remain unaffected.

During the maintenance window, affected Servers will be completely offline for up to 1 hour and 30 minutes while we perform infrastructure upgrades focused on improving:

  • Performance
  • Stability
  • Overall infrastructure efficiency

We will make every effort to complete the maintenance within the scheduled window and restore all affected Servers as smoothly as possible.

Scheduled maintenance:

📅 17 August 2026

🕛 12:00 – 13:30 EEST

We apologize for any inconvenience and appreciate your patience and understanding. ❤️

We will provide an update once the maintenance has been completed.

— neohost.ro